【服务器管理】Ubuntu18.04升级GLIBC_2.29,解决ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29‘

人工智能87

问题分析

个人在搭配transformers环境(Ubuntu18.04),使用时出现如下报错:

ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /home/xxxx/anaconda3/envs/xxxx/lib/python3.6/site-packages/tokenizers/tokenizers.cpython-36m-x86_64-linux-gnu.so)

分析上述报错,新版transformers的tokenizers需要2.29版本的GLIBC

查看服务器当前版本,命令如下:

strings /lib/x86_64-linux-gnu/libm.so.6 | grep GLIBC_

返回的结果如下:

GLIBC_2.2.5
GLIBC_2.4
GLIBC_2.15
GLIBC_2.18
GLIBC_2.23
GLIBC_2.24
GLIBC_2.25
GLIBC_2.26
GLIBC_2.27
GLIBC_PRIVATE

说明服务器当前是没有GLIBC_2.29的

安装GLIBC_2.29

下载

使用以下命令下载:

cd /usr/local
wget http://ftp.gnu.org/gnu/glibc/glibc-2.29.tar.gz

更高的版本可以在http://ftp.gnu.org/pub/gnu/glibc/下载。

进入超级管理员模式

输入以下命令然后运行密码

sudo su

下面的命令需要在管理员模式下进行

解压并配置

使用以下命令解压并进入glibc-2.29,创建build目录

tar -zxvf glibc-2.29.tar.gz
cd glibc-2.29
mkdir build
cd build/
../configure --prefix=/usr/local --disable-sanity-checks

上面的命令当中, --disable-sanity-checks起到关键的作用!

安装

分别运行以下命令

make -j18
make install

安装成功后大概返回如下图所示的界面,没有报错,说明安装成功!
【服务器管理】Ubuntu18.04升级GLIBC_2.29,解决ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29‘

建立软连接

使用以下命令查看下 /lib/x86_64-linux-gnu/libm.so.6的连接情况:

cd /lib/x86_64-linux-gnu
ll

在返回的结果当中,可以看到 /lib/x86_64-linux-gnu/libm.so.6软连接到 libm-2.27.so
【服务器管理】Ubuntu18.04升级GLIBC_2.29,解决ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29‘
由于前面配置时,设置了 --prefix=/usr/local,所以 libm-2.29.so被安装在 /usr/local/lib位置,我们可以把文件 libm-2.29.so复制到 /lib/x86_64-linux-gnu下:

cp /usr/local/lib/libm-2.29.so /lib/x86_64-linux-gnu/

进行强制软连接:

ln -sf libm-2.29.so libm.so.6

查看结果:

strings /lib/x86_64-linux-gnu/libm.so.6 | grep GLIBC_

Original: https://www.cnblogs.com/chenyirong/p/16342370.html
Author: 华工陈艺荣
Title: 【服务器管理】Ubuntu18.04升级GLIBC_2.29,解决ImportError: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29‘